Fabric Manager Services are not Functional

Symptoms

  • Uploaded blueprints/images do not appear in the list of images in the Fabric Manager.

  • Various buttons in the Fabric Manager are not functional.

  • Fabric Manager does not get loaded, is not accessible, or access to the Fabric Manager is very slow.

  • Database operations are affected. Because of this, you may notice

    • Events may not appear.

    • Part of the Fabric Manager is unaccessible.

    • You are unable to access the Fabric Manager.

  • FFM Server health stays in the Warning or Critical state for a long time.

  • Data, which was accurate earlier, is now inaccurate.

  • Status of the platform and partition images under CPF-System does not refresh.

  • Events are not updated.

  • Some of the operations are inconsistent.

  • Any other issues where the troubleshooting steps did not work (without an attempt to restart the Fabric Manager services).

Cause

Fabric Manager services are not working.

Solutions

  1. Ensure that no active operations are in progress such as partition or platform operations, and commissioning or decommissioning operations. If the operations are in progress, wait until they complete and a success or failure event is generated.

  2. Log out from Fabric Manager.

  3. Close all RDP client sessions to the Fabric Management Platform.

  4. Close all the applications and browser sessions that are running on the Fabric Management Platform.

  5. Close all remote browser sessions accessing the Fabric Manager.

  6. Log on to the Fabric Management Platform as root user using a ssh client like PuTTY.

  7. Close all the RDP client sessions using the command:

    #rcxrdp restart
  8. Use the following commands to start, stop, or check the status of the Fabric Manager services:

    • To check the status of the Fabric Manager services, use:

      #rcffmservices status
    • To stop the Fabric Manager services, use:

      #rcffmservices stop
    • To start the Fabric Manager services, use:

      #rcffmservices start

      After the services are started, wait 2 to 3 minutes before accessing the Fabric Manager from a browser session.

If the preceding procedure does not resolve the issue, reboot the Fabric Management Platform and restart the Fabric Manager services. Reboot the Fabric Management Platform in consultation with Unisys service representative your enterprise’s support person.

To reboot the Fabric Management Platform:

  1. Log on to the Fabric Management Platform as root user using an ssh client like PuTTY.

  2. Stop the Fabric Manager services using the command:

    #rcffmservices stop
  3. Reboot the Fabric Management Platform using the command:

    #reboot

Further Information

The following figures provide the information on codes for verifying the status of Fabric Manager services and their output.