Unable to Launch Partition Desktop: Installation Problem

Symptoms

Administrator or Operator is unable to access the Partition Desktop to do the following:

  • View the status of the partition image OS installation during the commissioning process.

  • Perform the initial configuration of the partition image after successful commissioning.

  • Troubleshoot the boot issues of the partition image.

Cause

  • User did not run the post install script after the ISO is installed.

  • The installation software for the Partition Desktop is corrupt or the initial installation did not successfully complete.

Solutions

Prerequisite

  • You are in the FM LAN environment and logged on to the Fabric Management Platform.

  • Platform is accessible through the FM LAN from the Fabric Manager and s-Par is running on the platform.

 

Procedure

  1. Log in to the Fabric Management Platform desktop and open a new terminal session as root user.

    (If you are connecting remotely, use a tool like PuTTY or the remote desktop function of the Fabric Management Platform and log in as root user. The root user login is root/Administer4Me.)

  2. Execute the following commands to verify that the software packages unisysauthservice, usyscon_partitiondesktop, and wine are installed.

    # rpm -qa | grep usyscon
    usyscon_partitiondesktop-4.4.5.28439-1.sles
    # rpm -qa | grep unisysauthservice
    unisysauthservice-4.4.5.28439-1.sles
    # rpm -qa | grep wine
    wine-1.5.28-232.1
 
  1. Execute the following command to verify that the services samba service, winbind service, and unisysauthservice are running.

    # rcsmb status
    
    # rcwinbind status
    
    # rcwine32server status
    
    # rcunisysauthservice status
    

    In the output of these commands,

    • “running” indicates the service is running.

    • “unused” indicates the service is stopped.

    • “failed/dead” indicates the service was not properly stopped.

 
  1. If one of the services is not running, execute the following commands to restart the services.

    # rcsmb restart
    
    # rcwinbind restart
    
    # rcwinbind restart
    
    # rcunisysauthservice restart
    

    In the output of these commands, “done” indicates that the service was restarted. “failed” or “dead” indicates that the service did not restart and includes additional text to indicate the issue.

 
  1. Execute the following command to verify that the user (administrator or operator) is added to the authentication database.

    # pdbedit –L

    A list of all the available users appears.

  2. On the FMP, access the Fabric Manager and launch the Partition Desktop. See Accessing the Partition Image Console (Partition Desktop) for instructions to access the Fabric Manager on the FMP and launch the Partition Desktop.

  3. If the Partition Desktop is still not accessible, execute the following command to reinstall the software packages.

    #/usr/local/ffm/scripts/./post_install.sh
  4. Use steps 2, 3, and 4 to reinstall and configure the Partition Desktop.